No targets to post to even when there are

@Sven - I know this is a persisting problem, so just wanted to let you know this thing is still there in 7.99. "No targets to post to" shows up on projects that have tens of thousands links to post to remaining. Maybe one of the things mentioned here would help remedy it?

Comments

  • SvenSven www.GSA-Online.de
    Well I put some work into it and can't find out why this happens. It would help to see what exactly was done right before that message was put out.
  • edited March 2014
    Hmm, I am running projects solely from imported lists and global identified, so by default I have no serch engines checked. There is only one file I imported for each project so it shouldn't be that, maybe it throws the message when it finishes reading one list from the identified folder, hmm. What kind of data do you need? Will the log show something?
  • SvenSven www.GSA-Online.de
    hmm yea the log should give the time and what happened before that message.
  • ok, have to do some testing anyway, so I'll log it as well :)
  • edited March 2014
    Test #1 - two projects running the same list each imported. No global lists, no search engiones, no nothing. Last few lines grabbed off the screen - http://pastebin.com/0EnFyRfM

    pls notice the "Attention! No targets to post to (no search engines chosen, no site list enabled, no url extraction chosen)" appears 15 times for just two running projects.

    After I posted the log the projects are still set to active and the message still appears regularly every 4 minutes (you can separate the projects by lookign at the number of seconds - #1 is :41, #2 is :31):
    10:48:41: [ ] Attention! No targets to post to (no search engines chosen, no site list enabled, no url extraction chosen)
    10:48:41: [ ] Attention! Option "Verify submitted links" is disabled in project options.
    10:50:31: [ ] Attention! No targets to post to (no search engines chosen, no site list enabled, no url extraction chosen)
    10:50:31: [ ] Attention! Option "Verify submitted links" is disabled in project options.
    10:52:41: [ ] Attention! No targets to post to (no search engines chosen, no site list enabled, no url extraction chosen)
    10:52:41: [ ] Attention! Option "Verify submitted links" is disabled in project options.
    10:54:31: [ ] Attention! No targets to post to (no search engines chosen, no site list enabled, no url extraction chosen)
    10:54:31: [ ] Attention! Option "Verify submitted links" is disabled in project options.
  • edited March 2014
    And the icon keeps reappearing :P over and over and over and over and over and over and over again ....
  • SvenSven www.GSA-Online.de
    whats wrong with that log ? If you look at it, it has no tagets and put out that message of course to get your attention. I don't see anything wrong on it.
  • edited March 2014
    ok, how will it behave when you have scheduled posting on? - like in this case, at 10:51 there were no targets to post to, but at 15:50, I had a whopping 160 targets for the project to parse (and I just had 550 submitted to start with - that is 30%). The message would still be there and SER would still be posting - but technically it is out of primary targets, so how do I know it is?
    e.g. With a list of 70k targets I would get 21k still to post to AND an out of targets message. Is that the way it works?
  • SvenSven www.GSA-Online.de
    basically this message appears if SER was unable to start new submissions threads for a longer time. It does not matter where the targets come from.
  • edited March 2014
    Would it display a "no targets to post to message" when the {list is|lists are} finished, but scheduled posting is enabled (let's say with a delay of 120 minutes)?
  • I actually see this issue all the time on my projects too. It even happens to a new project that was just created and have status Inactive.

    The common thing I noticed is that those are usually tier projects getting these warnings. For now, I just ignore those. Don't want to turn it off as I sometimes it shows email errors so it's useful.
  • SvenSven www.GSA-Online.de

    @Ferryman yes


  • BrandonBrandon Reputation Management Pro
    I know the answer to this question!

    SER grabs urls in bulk usually about 15,000 at a time. If you have 10,000 Target URLs, it will grab them all and start running them. When it tries to grab more URLs, there are none left so it gives you the message even though it is still running the first group is grabbed.
  • edited March 2014
    Yay, 100 points for @Brandon :D Would be nice if it considered the fact that it is still running URLs though, or the message were changed to something more fitting.
  • SvenSven www.GSA-Online.de
    Hmm no, actually it first reads out new urls from the file and starts a thread and only if that fails it shows that message.
  • @Sven as I understand this error shows up right away first time when SER finds no target (for some reason). Maybe to show it after 3-4 failed attempts? Just a thought.
  • SvenSven www.GSA-Online.de
    well it waits like 5 minutes already...if during that time nothing could get started, I think it's ok to give that warning.
  • Hm..then I'll keep scratching my head  #-o Can't find a pattern so far
Sign In or Register to comment.