Unsupported Request Method and Protocol (proxy error?)

A lot of "no form at all" with this error on html page:
Should i contact proxy provider or provide more logs ?

ERROR

The requested URL could not be retrieved


The following error was encountered while trying to retrieve the URL: $deleted_url

Unsupported Request Method and Protocol

Squid does not support all request methods for all access protocols. For example, you can not POST a Gopher request.

Your cache administrator is webmaster.



Comments

  • andrzejekandrzejek Polska
    edited June 14
    I guess its beacuse SER is not handling status codes, or proxy issue with http version? (logs sent via pm).
  • Logs sent to proxy provider.
  • So if i understand correctly SER is using GOPHER under the hood?
  • This is reply ive got from proxy support:

    GSA doesn't use Gopher , is using HTTP protocol. Also the proxies are working fine with GSA

    but I don't know how you use GSA that you got those. The proxies must be put in GSA, not an external program

    yes Gopher isn't supported anymore, as wikipedia is saying "The Gopher ecosystem is often regarded as the effective predecessor of the World Wide Web." so is something very old and not used anymore

  • andrzejekandrzejek Polska
    edited June 14

    support: yes, I've google it a bit

    501 error code from LiteSpeed (the server which runs that site) is actually a ban from mod_secuirty (some firewall which runs on that server)

    so it doesn't have to do with the proxies, is a security feature from that site

    You probably can see on other request to other sites that the proxies are working normally


    Which is obviously not true beacuse without proxies requests work just fine.

  • SER without proxies: WORKS
    SER with proxies: DOES NOT WORK

    BROWSER without proxies: WORKS
    BROWSER with proxies: WORKS
  • support:

    yes, I also tested in a browser and was working on that URL but I believed that GSA hit some firewall rules on that site

    if you have antivirus, please disable, sometimes is blocking the connections
    please reset GSA , we saw many cases when a restart made it work

    port 80 might be bad on your network, you could also try with port 55555 (is the same list, just port 80 was changed)

    After changing proxies to port 55555 everythjing works fine and this error does not appear. @Sven do you know what just happend?

Sign In or Register to comment.