Link building is Extremely Slow

I am a newbie. Hope anyone can help me to solve the issue.
I purchased GSA Ranker, GSA Content Generator and and Captcha Breaker. And use 10 semi-dedicated proxies from buyproxies.org. 
When I ran GSA Ranker, the link building is EXTREMELY slow. 5 verified backlink in more that 5 hours. My setting is totally the same as the tutorial of Matthewwoodward. I have clicked all Search Engine Options, but it still didn't works.
Just wondering what I can do. Help!

Comments

  • SvenSven www.GSA-Online.de
    Accepted Answer
    any details seen from your log?
  • 710fla710fla ★ #1 SER VERIFIED LIST serpgrow.com
    Accepted Answer
    Are you using a verified link list or letting GSA SER scrape for target sites using search engines?
  • AllenAllen China
    710fla said:
    Are you using a verified link list or letting GSA SER scrape for target sites using search engines?
    I didn't use that. How to do that? Could you suggest any tutorial? Thank you
  • AllenAllen China
    Sven said:
    any details seen from your log?
    Is this the log? Many "no engine matches"  and download issues. Is therea way to solve it?
  • SvenSven www.GSA-Online.de
    You are using public proxies for search engines? That seem to be many proxies you use here, so make sure they are all working and constantly checked (at least public).
  • AllenAllen China
    When I choose to ONLY use private proxies, it is still extremly slow. Is that normal?
  • SvenSven www.GSA-Online.de
    again, what about some details here...logs?
  • AllenAllen China
    Sven said:
    again, what about some details here...logs?
    Do you mean the detail setting of Option and Project? If not, where can I see it?
  • SvenSven www.GSA-Online.de
    i mean some log lines as with your last screenshot.
  • AllenAllen China
    Where I can find log line information?
  • AllenAllen China
    I also got many issue of "no space within Anchor text", can I fix this issues?
  • SvenSven www.GSA-Online.de
    What you see in the log are the footprints for the sites SER is searching for. Nothing to worry about that.

    Whats strange is, that among these footprints, it's using your very long keywords with quotes as well. And these keywords are so uncommon that no result is found.

    Are you using the option to always take your keyword on a search? If so, it's the reason for getting almost no target.

    Also check your proxy setup please (if you use any).
Sign In or Register to comment.