Base64 encode error

TayTay Brazil
Gsa CB is sending the captcha task in binary, example:

{
"clientKey": "myClientKey",
"task": {
"type": "ImageToTextTask",
"soft_id": 394,
"body": "?PNG\r\n\n   \rIHDR   x   !\b   ?o?  ,?
 ,?IDATx?{w?????F??5 ??R??~??^???\b?\b??]B!\r?bo?n?????z?=???s??
?????/$?????x?9g??w???{??W5?`M??BaU??PY^???ZT????g??Q????8W???
...a lot of binaries...
\"?C??N??BX    IEND?B`?",
"languagePool": "en",
"phrase": false,
"case": false,
"numeric": 0,
"math": false,
"minLength": 0,
"maxLength": 0
}
}

I already tried to change the "base64 encode=1".


Thanks in advance! 

Comments

  • SvenSven www.GSA-Online.de
    hmm but it is set to base64 encode=1 by default anyway?
  • SvenSven www.GSA-Online.de
    If possible provide your api key and further details in pm to debug it.
  • Sven said:
    hmm but it is set to base64 encode=1 by default anyway?
    Hmm tried every single possibility, = 0, = 1 and even not set... it always comes out as binary.

    Sven said:
    If possible provide your api key and further details in pm to debug it.
    Sadly, our company is kind of restrict regarding this kind of thing, sending you our API key would require us to refresh it later and change it on a bunch of systems.

    You could reproduce it without a key or using a random one, just fire up an interceptor like Wireshark, that's how we found the issue.
  • SvenSven www.GSA-Online.de
    yea, sad you don't trust me but it's ok.

    Though I have tested this already and it is encoding the image correctly for me before sending it to antigate.

    Can you at least describe what you do exactly to make me reproduce it? All my tests so far show it being encoded and send correctly.
Sign In or Register to comment.