Proxy Scraper doesn't turn off

Hi @Sven,
Could you have a quick look at the proxy scraper, please. It doesn't turn off. Or maybe I'm just not patient enough?
Anyway the the webserver is turned on on 8080 port an using proxy scraper to serve proxies for scrapebox and after a while it slows down or rather stops serving the proxies. When I stop PS with the task manager and start it again everything returns to normal.

Comments

  • SvenSven www.GSA-Online.de
    if it slows down or has issues shutting down, simply click help->send bugreport and make a note to this thread
  • OK done
  • SvenSven www.GSA-Online.de
    The issue is the domain resolving...for some reason it hangs on your pc....i try to fix that but this is not normal and should not happen.

    Any anti virus/firewall that might block this?
  • OK thanks! I've just updated and I'll report back in case it still has an issue. Or just turn off domain resolving. I'm not even sure why is it turned on.

    I only use Windows 10 built in defender without modification.
  • Hey @Sven, it is still doing it. I can't turn PS off.

    I was trying to turn off domain resolving too and realized that there is no such settings in PS. It's a SER feature and I turned it off there but I'm not using PS with SER. I use it with Scrapebox which I don't think has any such settings.
  • SvenSven www.GSA-Online.de
    PS resolves the ip to a domain once it needds to find out where that proxy is located (export filter).

    Can you send again some bugreports to see if it's suck at the same location?
  • Sorry for being slow on this.
    I've sent the new report.
  • Also I have checked the proxy export and I haven't got IP resolving ticked in any of the exports. So basically IP resolving is turned off.
  • SvenSven www.GSA-Online.de
    No, you still don't understand. This is no option in the program that you can turn on/off. Domain to IP resolving is done to e.g. resolve the country to a proxy.
  • Oh, I thought this is an option like it is in SER. No one else is having an issue with it just me?
  • SvenSven www.GSA-Online.de
    nope, you are the only one Im afraid :/
    maybe something odd on your dns server setup? Try using an alternative one like 1.1.1.1
  • edited September 20
    If you use a lot of threads on the internal proxy server, GSA PS will try to resolve the remaining threads before closing. When you're finished with whatever you're using it for, you either have to force-close it, wait for a while... or, alternatively...

    You can download TCPView by Microsoft and close the pending GSA PS sockets... Most of them will be in either TIME_WAIT, or FIN_WAIT1. You will see them marked as GSA PS in the program (just select them and right click -> close). This will "allow" GSA PS to shut down properly. Usually I just force close though.
    Thanked by 1TheGypsy
  • Thanks seoaddict! My real problem wasn't really that it didn't shut down as I don't really mind force closing it either. Thanks for the TCPView tip I'll check it out as still don't know what's using the port 80.

    What bothered me is that I use it with scrapebox and PS stopped serving the proxies for it. I couldn't change DNS server to 1.1.1 or any other number as Sven has suggested though as all that I tried was used the by another program.

    I had to change the port. Currently it uses the 443 and it seems to be working now. I was going to ask @Sven if he has a recommendation for ports apart from the default 80. Or whichever port works it's fine?

Sign In or Register to comment.