Windows 7 Services required for proxies to work?

0
Hello,

I recently reformatted my PC and disabled a lot of services to speed up Windows 7.

I run GSA on low-threads, 5-10, with 100 private proxies. I'm noticing the connections in my router (DD-WRT, 16k max connections) piling up quicker than before... and looking at the active connections, it appears as if my local IP is resolving the sites, opposed to connecting to the proxies first?

@sven Could you help me figure out if this is the case and what Windows services are required for proxies to work properly?

If I had to guess, I'd say:

IP Helper (? I had this disabled, but notice in the description -- Provides tunnel connectivity using IPv6 transition technologies (6to4, ISATAP, Port Proxy, and Teredo))
SSDP Discovery (There are no homegroups / network groups on my network. No file-sharing. I only use Teamviewer).
UPnP Device Host
IP Helper
Server
Workstation
TCP/IP NetBIOS Helper

Do either of these services being disabled prevent GSA from using proxies? If not, do you have any recommended TCP/UDP timeout settings that could help decrease the connections / still allow me to browse the web properly?

Update: It's really hard to say if any of these services have an impact on GSA's ability to use proxies. I tested with enabling and disabling them, and it seems to be the same result, I'm not really seeing any leaks. But the connections are moving up faster than I'm used to.

My default DD-WRT settings are:

TCP Congestion:
Westwood

TCP timeout
3600

UDP timeout
120

Should I make these lower?

Comments

  • 0
    edited May 8 Accepted Answer
    After more testing, it seems like the only service that has any impact on software using proxies is:

    WinHTTP Web Proxy Auto-Discovery Service
    Also, proxy settings should be set to "Automatically configure".

    And potentially,
    WebClient

    Otherwise, I manually disabled and tested the other services and saw no difference. It seems so long as the above service is set to "Manual" and Auto-detect is in proxy settings, GSA is able to properly use the proxies without and leaks.

    Pretty sure this is case closed... Besides any suggestions about TCP/UDP timeouts... :)
  • 0
    SvenSven www.GSA-Online.de
    I got nothing to add really. DNS resolve should be turned on in proxy options to not execute a new task for domain->ip resolve. That will however keep some proxies disabled as they do not perform dns-lookups.
Sign In or Register to comment.