GSA CB Writing to host file even when not set to simulate

0
royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
edited November 2015 in Bugs
@sven

I have some custom redirects in my host file, but everytime i start GSA CB it strips my custom entries in the host file.
I dont have any of the options checked in GSA CB to simulate or to run as web server, so why is GSA CB still writing to host file.

Sven please fix GSA CB to NOT write to host file when non of the simulate options are selected

Comments

  • 0
    mashafeeqmashafeeq iraq
    Accepted Answer
    go to 

    C:\Users\[user]\AppData\Roaming\GSA Captcha Breaker

    and open the config file

    then just remove the hosts 
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    Thanks @mashafeeq
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    @mashafeeq  sorry that did not help at all.
    I removed all of the host in the config file, saved it.

    Then i restarted GSA CB and it again added all the host back into the config file, also activated to simulate some services

  • 0
    just open ur skype i will pm u there
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    edited November 2015
    @sven This is what the host section inside my config file looks like :

    [host modify]
    on=0
    decaptcher=0
    bypasscaptcha=0
    dbc=0
    captchatypers=0
    captchatrader=0
    antigate=0
    captchabot=0
    fasttypers=0
    beatcaptchas=0
    shanibpo=0
    imagedecoders=0
    linkassistant=0
    captchax=0
    pixodrom=0
    ripcaptcha=0
    webvisum=0

    However when i restart GSA CB it is still messing with my host file and remove the entry i have for : xx.xx.xx.xx api.captchax.com


  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    it seems it is ignoring ( on=0 ) and still write to host file.
  • 0
    SvenSven www.GSA-Online.de
    host is modified even though you have it turned off. Thats because if CB e.g. crashes and was not closed correctly, it still would have the entries in it which should be fixed at least on a new start.
    What redirects are we talking about here anyway?
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    edited November 2015
    @Sven

    What does crashing of gsa cb has to do with the host file. I DO NOT have the option checked to similate -- therefor  GSA CB should NOT write or edit the host file.

    I have this in the host file :
    xx.xx.xx.xx api.captchax.com

    everytime i restart gsa cb it removes it
  • 0
    SvenSven www.GSA-Online.de
    well if this is still part of the host file and CB sees the option is actually turned off...it has to remove it, else it's simulated for CB.
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    edited November 2015
    @sven

    I can understand that it will edit will edit the host file if i have enabled to simulate any services.
    But when it is like below screenshot where  the option to simulate is not checked, then GSA CB should NOT edit the host file

    If
    on=1   - then edit host file

    If like below image
    on=0   - then skip edit host file


    image





  • 0
    SvenSven www.GSA-Online.de
    Well "api.captchax.com" is one of the simulated services. If you turn that option off, then CB has to remove it, else it is not according to settings.
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    @sven Please just answer me this : I dont  check anything to be simulated so WHY does it still have to edit the host file.

    I have captcha x checked in GSA SER and sending to an external service via host file redirect. I dont want GSA CB to edit every time i restart it.

    why cant you just add a rule like:  if [host modify] \ on=0   - then skip edit host file
  • 0
    if as sven said 

    that the gsa cb didnt exit then

    ctrl+alt+del
    then go to process
    then select gsa cb process and click end process

    it will exit from it totally

    then go edit the host file manually

    then open gsa cb
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    edited November 2015
    I dont want to edit the darn host file everytime i restart or update gsa cb.


  • 0
    SvenSven www.GSA-Online.de
    Accepted Answer
    Well  I just can't and don't want to change the way CB works on the modification. However I got a solution for you in pm.
  • 0
    royalmiceroyalmice WEBSITE: ---> http://asiavirtualsolutions.com | SKYPE:---> asiavirtualsolutions
    Sven, Thank you very much the PM solution works perfect.

Sign In or Register to comment.